Hum problem with LP125m SE

From tubes to solid state.
User avatar
roberto
Super Pro
Super Pro
Posts: 109
Joined: Wed Aug 01, 2012 11:02 am
Location: Costa Rica.

Re: Hum problem with LP125m SE

Post by roberto » Tue Feb 06, 2018 12:50 pm

Hola. Ground loops!. There is a very small potential difference between the ground cables, and this little difference, the 60Hz from the main line is induced.
Because of this reason, I use another copperweld bar dedicated to my AC to my dedicated circuit of 30A, to power all my system. Having a dedicated AC line for my room, made to have cleaner AC. Also I am using a BALANCED power line stage. Right now I have a 80 pound BPT Signature 3.5 Plus, (http://www.6moons.com/audioreviews/bpt4/plus.html) and this solved all my noise and hum problems. I recommend this to all of you. This is making to sing my system as never before. Buyt it used. Or use a big massive toroidal transformer for this. There are some DIY available and a very fair price.
Happy listening!
ML CLX speakers, BF-210 sub, Classic One Twenty SE amp. ET-7 C-J pre. Exasound E-32DAC, Mac Mini i7, Anthem MCA-3 power amp, Anthem AVM-60, Oppo BDP-103. ML Stage X Center, Motion 4, BPTSignature 3.5 Plus condiciones.

User avatar
roberto
Super Pro
Super Pro
Posts: 109
Joined: Wed Aug 01, 2012 11:02 am
Location: Costa Rica.

Re: Hum problem with LP125m SE

Post by roberto » Tue Feb 13, 2018 9:58 pm

This is the principle that I have now...check it out.

http://www.equitech.com/articles/bpng.html

Happy listening!
ML CLX speakers, BF-210 sub, Classic One Twenty SE amp. ET-7 C-J pre. Exasound E-32DAC, Mac Mini i7, Anthem MCA-3 power amp, Anthem AVM-60, Oppo BDP-103. ML Stage X Center, Motion 4, BPTSignature 3.5 Plus condiciones.

Post Reply